Cisco BGP config example

Interface Configuration

interface RELEVANT-ETHERNET-INTERFACE
ip address 218.100.0.x 255.255.255.192
no ip directed-broadcast
ip access-group [ACL] out

Router Process Configuration

router bgp YOUR-AS
no synchronization
bgp log-neighbor-changes
no auto-summary
neighbor 218.100.0.1 remote-as PIPE-AS
neighbor 218.100.0.1 soft-reconfiguration inbound
neighbor 218.100.0.1 description PIPE-BRISBANE-IX
neighbor 218.100.0.1 filter-list [IFLST] in
neighbor 218.100.0.1 filter-list [OFLST] out
neighbor 218.100.0.1 distribute-list [IDLST] in
neighbor 218.100.0.1 distribute-list [ODLST] out
neighbor 218.100.0.1 route-map [PREFER] in
neighbor 218.100.0.1 remove-private-AS

NOTE that expressions inside of [] are to be replaced with local versions of ACL, filter list or Interfaces.

[ACL]

This *SHOULD* be an ACL that will prevent IP packets being spoofed from your network. PIPE only filters routes - not packets. Good practice says you should use filters to ensure evil does not spread from your network.

[IFLST]

This is a filter list that filters everything you get in from PIPE IX. These can be found on the PIPEdb customer page under "AS PATH Filter". Note you will have to modify these in order to insert your own AS PATH in the expression. The as-path access lists available are an example of what PIPE uses on your connection.
If you register a "Notification Email Address" against your connection in PIPEdb then you will get updates of filters and distribute lists whenever these change.

[OFLST]

This is a filter list that will filter your announcements to PIPE, it may look like;

ip as-path access-list [OFLST] permit ^$
ip as-path access-list [OFLST] deny .*

NOTE: This will not work if you transit other AS.

[IDLST]

This is a distribute list that specifies what routes you will accept from PIPE Networks. A version of this can be found on the PIPEdb under the "Router Filter" link.

[ODLST]

This is a distribute list that specifies what routes you will send us. If you have entered up to date routing data in PIPEdb, this is also available under the "Route Filter" link.

[PREFER]

This is a route-map that you may wish to deploy. Peering at PIPE is typically a high quality and cost effective way to receive traffic as an alternate to a transit Internet feed. Depending on your other connections and peers, you may want to influence BGP path selection.
If BGP path selection is not handled correctly then it could lead to instances where you accept routes of PIPE Networks peers but instead prefer another path to that network. This will result increased traffic costs and most likely a different level of quality between networks.

route-map [PREFER] permit 10
set weight 500
set local-preference 1500

This will ensure that PIPE Networks routes are preferred by your router and other inside your AS. You may not wish to do this due to entirely valid engineering reasons, however it will be worth noting that if you receive traffic from a certain AS via PIPE Networks then you *should* reciprocate and send traffic back to that network via PIPE Networks.